7

Phone shows miles, car play shows kilometres

  • Done

Avatar
Paul Custance

I recently did a long journey and got to really test ABRP. One issue I found was that my units are set to British but often but not always when I connected to Car Play it would show everything on kilometres. I’ve attached screenshots showing the car play and my mobile.


A

Activity Newest / Oldest

Avatar

Katya_ABRP

Status changed to: Done

Avatar

Katya_ABRP

Hi all,

As Samuel replied to another thread about this issue it should be resolved in the new version of CarPlay support, as of version 4.2.0. Please make sure you've got the most recent version of the app installed.

Should you however still see it happen simply comment here (or submit a new bug report) and I'll have it reopened.

/Katya


Avatar

Katya_ABRP

Merged with: Units changed from imperial to metric

S

steve purdy

Fo some reason the units changed from imperial to metric, even though the settings still stated imperial

I am using IOS with dongle for live information


Avatar

Samuel_ABRP

This is fixed in carplay now. Please update to latest 4.2.2 which was released yesterday and should be available soon in app store.


S

Steve Nichols

I have a Mustang Mach E and use Apple carplay. I plan my trips in miles and it always shows correctly on my phone.. However, the carplay display will sometimes shift to kilometers and app and car must be restarted to get it to display correctly again in miles.


Avatar

Samuel_ABRP

Merged with: Carplay display shifts to kilometers

Avatar

360529

We are working on a rebuild of car play that will be released in the coming weeks. Most probably this issue will be solved in that release


S

steve purdy

in car play, I believe, but I am not 100 percent. I will need to check it out next time and let you know


Avatar

Samuel_ABRP

Hi,
Does this happen on CarPlay or in the app?


R

Rob Budge

I have imperial set, but when using live data, the CarPlay displays km and not miles.


Avatar

Samuel_ABRP

Merged with: CarPlay with live data shows km

B

Burns Fisher

Version 4.1.9 on iPhone/Car play. In US so using imperial measurements. I parked briefly, turning off the car. When I came back and re-started, ABRP had switched to metric. In addition, the battery SOC had switch to some low value (maybe a default of some sort since EVNotify had stopped updating). I pulled over, hit "end navigation" and entered the destination again. Now it was ok.


Avatar

Samuel_ABRP

Merged with: Uncommanded metric/imperial switch

B

Burns Fisher

Given Jonathan's report, I'll add that I do not have wireless CarPlay. Only wired on a 2019 Chevy Bolt.


  • Avatar
Avatar

Jonathan Fitt

I am experiencing the same thing on iOS using wireless Carplay. Once it switches to metric there doesn't seem to be a way to get it to switch back besides force-killing the app.


B

Burns Fisher

Happy Christmas to all, and I hope you are not working today. I had some additional info though and wanted to write before I forgot it. I'm now pretty convinced that the uncommanded imperial-to-metric switch is related to using ABRP both on Car Play *and* on the iPhone itself. I have had other problems that get solved by opening the iPhone app (while it is showing on CarPlay) and force-killing the app on the iPhone, then starting it up again. Frequently this results in the switch to metric on Car Play although it is still showing Imperial on the iPhone screen. Usually, but not always, "End Navigation" followed by "Plan" and "Launch" gets things back to Imperial.


B

Burns Fisher

Ok, I tried it again on Version 4.1.11 (beta) using APRB live data and it did not happen again. Of course this could be simply because it is intermittent or it could be that EVNotify was involved, or it could be that it is fixed :-). If it happens again, is the data sent by clicking Support and Feedback/Contact Support/Upload Usage History going to be useful for this sort of problem? I'll do so if it is.


B

Burns Fisher

You are correct that I can't reliably reproduce it. It has actually happened on an off for months. I'm in the process of testing APRB direct OBDBLE with Bo and Samuel, but when I can, I'll try what I said above.

I will say that this was not the first time it has happened. I talked with Katya about it via email previously, but then the problem did not happen again till this stime.


Avatar

360529

Hey Burns, is this an issue that has happened many times or it's just this one instance? Based on your story it sounds like you don't know how to replicate it but maybe you do and in that case please share it for us as it would speed up our work to find what caused this.


B

Burns Fisher

Ok, it happened again, and here is a bit more information. It seemed to switch over while driving when I decided to use a different route than ABRP was telling me. I went straight rather than turning left (I was going to take a later left). I send an email from the "Support and Feedback" button and said "yes" to send data. Hopefully this is helpful.
This is on 4.1.11 (beta) using ABRP built-in OBDBLE, although I'm not sure that is related.


Avatar

Samuel_ABRP

Do you maybe use alternative routing engine? Or are you still at defaults?


B

Burns Fisher

All defaults. BTW, it does often work to find a new route. This particular time that seemed to be what triggered it to switch to metric,


B

Burns Fisher

No, just the defaults for the .11 beta version. And it has correctly rerouted sometimes. Sounds like some weird array overflow or bad pointer????


B

Burns Fisher

Forgot to say: This is on a 2019 Chevy Bolt using EVNotify on the same iPhone (with display sleep turned off) as ABRP.


Avatar

Samuel_ABRP

Merged with: Miles in app, km car play

Avatar

Carsten Ackermann

I often have the problem where the app in CarPlay is using metric units, despite the app is using imperial units


Avatar

Samuel_ABRP

Status changed to: Investigate