17

No "save" button for OBD connection

  • Done

J
Jared B.

When using current version of ABRP, I attempt to connect my OBDLink CX. I'm able to start the process, see the OBD listed, and it successfully makes a connection to car. However, a pop-up says to press the "Save" button to save the connection. Unfortunately, the button is missing and it won't save the connection. The second I press the back button on the app...the connection is lost.

Phone: Samsung Galaxy Note 10+
OS: Android 12
ABRP version: 4.2.6


A

Activity Newest / Oldest

Avatar

Fredrik T

I have a Kia e-niro and vgate icar pro obd adapter. It looks like everything is working but after dialog with success message the car setup still shows option to connect and does not activate live data. Bluetooth led on OBD adapter is active when "ABRP OBD Connection" page is visible but turns off when returning to app main screen.

What might be wrong? Looks like it should work... I have attached screenshots from the app.


Avatar

Katya_ABRP

Merged with: OBD configuration not saved?

Avatar

Fredrik T

Suddenly when I tested again after adding this bug-report a save button appeared. You can close this issue, it is solved and working great now. Thanks :)


  • Avatar
Avatar

Katya_ABRP

Hi Fredrik,

Yes! We resolved this yesterday but one may need a reboot of the app / clear cache in order to get the fix.

Other report: abrp.upvoty.com/b/report-a-bug/no-save-button-for-obd-connection

/Katya


Avatar

Katya_ABRP

Merged with: Saving of Dongle connection

Avatar

Klaus Dietrich

Hi!

My dongle connects with the App and the car but I am unable to save the connection.

Please debug :-)


Avatar

Bo_ABRP

Status changed to: Done

Avatar

Bo_ABRP

This has now been fixed and you should be able to get the update if you force close the app and open it again (build number 996). Thanks for all the feedback!


Avatar

Katya_ABRP

Merged with: There is no button to save configuration

T

Tomas


Avatar

Katya_ABRP

Merged with: Cannot save Bluetooth connection.

Avatar

Björn S

Does connect, but cannot save. Don't get the "save" option anymore (since I upgraded to Premium). iCar Pro dongle.


V

Vincent van Wees

Vgate vlinker mc+, kia ev6, samsung a52s, android 12. All software latest versions.
Have been using the obd connection as standard user, worked flawlessly.
Since yesterday Premium user, can not make a connection. Connecting works, app finds the dongle, everything ok. At end of connection process there is no "confirm" to tick, can only go back with the android arrow, it then seems the connection is not saved.
I have set the "use live data" switch


Avatar

denis WELLER

Hello
with version 4.2.6 it is not possible to save the pairing of the dongle
it works fine with 4.2.5
backup buttons no longer appear on iphone xr


P

Paul Paul

Hi,

The OVD is linked ask me to save , there is not save button though…

share.icloud.com/photos/0d9O4qXHy1Bg3FdjTaMNM7AKA


Avatar

Fredrik Bjurén

Cant add obd dongle, nothing happends after sucessfully adding device. Only back Button working and no saving of obd.


Avatar

Quinn Nash

I have this same issue as well.


P

Paul Paul

Same here absolutely impossible to use it


J

Jared B.

Yeah. I'm heading out on a 2 week road trip on Tuesday and was really hoping to be able to use the ODB data for accurate battery levels, etc. At the moment, it's unusable.


P

Paul Paul

Awesome thx


J

Jamie Olger

Same here, I disconnected it somehow and now I can’t get it back to save.


J

Jamie Olger

Same here! It says to save but it doesn’t give me an option to save.


Avatar

Jason Ryszka

Same with Android 12 and Vgate iCar Pro OBD in an EV6.


Avatar

Jason Ryszka

Same here with Android 12 and Vgate iCar Pro OBD in an EV6


J

Jared B.

Here is the screenshot after making a successful OBDLink CX connection and it states to press the save button. However, no save button is present.


Avatar

Thomas Wohlhüter

Hi Jared
Can you please post a screenshot of this pop-up?


B

Bert Roos

Same issue here, on a Samsung Galaxy S10 running Android 12


J

Jari

Same with iOS and Vgate iCar Pro OBD device. Connection established and seem successful, but no save button to press.

OS: iOS 15.5 / iPhone X
ABRP 4.2.6


Avatar

Samuel_ABRP

Every change in the settings is saved automatically. Is there any setting that is not saved for you?