1

Navigation locks up, no more SOC transmission from OBD2


Avatar
Matthias Dongus

I have ABRP connected to my Hyundai ioniq with a OBD2 adapter. Recently the navigation either completely locks up or lags behind several hundred meters. SOC doesn’t update anymore either when this happens. Also the OBD2 adapter‘s lights indicate that there might be a connection problem, although ABRP says it is connected at the same time. I changed in the preferences that the position of the device overrides the position of the car, but that didn’t make any difference. Unfortunately this has made ABRP completely useless for me. I hope you have an idea how to fix this problem.

A

Activity Newest / Oldest

Avatar

Katya_ABRP

Status changed to: User Feedback

Avatar

Katya_ABRP

Hi Matthias,

Could you specify where this occurs? Android app, iOS app, CarPlay, Android Auto or several of these?

/Katya


Avatar

Matthias Dongus

I use an iPhone 8 with CarPlay and an OBDLink CX. This probably usually doesn’t occur on short trips. But as soon as it is a bit longer, the navigation navigation locks up after a while or lags a couple of hundred meters behind. The last trip was about 400km. I also found that the OBD light on the dongle also goes out when this happens. I tried 2 different iPhones and also another dongle and the problem is still the same.


Avatar

Sofia_ABRP

Hi Matthias,

Are you still having the same issues since the last update (4.2.6)?

You mentioned that you've tried another OBD dongle. Is it also an OBDLink CX? You could try updating the firmware of your OBD device to the latest version.

Are you using CarPlay with a wire, or wireless?

The iOS app can only communicate with the OBD device if it's running in the foreground. Exiting the app will pause the connection. However, while using CarPlay the app should behave as if it's running constantly. Are you noticing the issue in when switching apps on your phone?

/Sofia