2

Navigation arrow stuttering / updating position only every second since android 12


M
Michael Frech

Navigation arrow on android Auto Screen is updating position only every second and feels like its stuttering after android 12 update on pixel 4 and galaxy xcover pro. With android 11 on galaxy xcover pro it was working perfectly and the blue arrow is moving very smoothly. The "stuttering" is very irritating whilest driving and forces you to look at the screen every so often. Would like to see the arrow move "smooth" again. Best regards Michael

A

Activity Newest / Oldest

Avatar

Samuel_ABRP

Status changed to: User Feedback

Avatar

Samuel_ABRP

Hi, do you still see the slow position update in 4.2.5? We actually have some pixel devices and could not reproduce it with them, however other devices like xiaomi have some problems, which we are currently looking into.


M

Michael Frech

Hy. On my pixel 4 i can still see the problem. I have attached 2 pictures. In one picture you can see the blue dot is ahead of the red arrow and in the other picture you can see that the red arrow has picked up with the blue dot. This happens all the time while driving. This pictures are Frame exports of a screen record while driving. This behavior translate to the android auto screen. There i cant see the blue dot but i can see the red arrow jumping every second to the "actual"position. For reference: i have enabled "high location accuracy" in my pixel's location settings. Turned off all energy optimizations and granted all permissions. Hope this helps. If you need more informations feel free to contact me.


Avatar

Alexander Bachert

Same problem for me.
Since update to Android 12/MIUI 13 on Xiaomi Poco F3, the Android Auto arrow is only updating when ABRP is also opened on phone with unlocked screen. When locking the phone screen or switching to evnotify for correct display of SoC the arrow for my position stops updating while the instructions, for e. g. my next turn, are keeping to do so.

Also the Android Auto part of ABRP is only showing the correct position of me/my car on startup when I open ABRP on the phone.

With the first problem ABRP is currently useless for me so I have to navigate with Google Maps or Sygic.


Avatar

Samuel_ABRP

This sounds more like this issue:
abrp.upvoty.com/b/report-a-bug/map-doesnt-update-on-android-auto-when-phone-display-is-off/

You can subscribe and upvote that one so it get's more attention.