3

LeafSpy linking page doesn't generate token


Avatar
David Ebling

When trying to link to leafspy, it just gives me $token$ as the token. This doesn't look right. Even if I wait it never makes a token. If I go to the generic link page it generates a token as expected after a few seconds.

What am I missing? Also, is the URL shown correct, I habe heard that the URL ending "leaf40" may be out of date? In which case the guidance screenshot needs updating in the LeafSpy linking page.

A

Activity Newest / Oldest

Avatar

Katya_ABRP

Hi all,

You can grab the actual token presented under the ‘generic’ connection option to make the LeafSpy connection work before we’ve updated the UI.

/Katya


  • S
S

Sébas van der Voort

Thanks for the reply. I am not able to find the option in the Android App.
Where should this function be found?


Avatar

Katya_ABRP

Hi Sébas,

Try swiping the card horizontally for viewing other options.
(On the vehicle settings page that is, same as for where you'd ask to link LeafSpy)

/Katya


  • S
S

Sébas van der Voort

I seem to get the same problem.
tried rebooting my phone.
Uninstalled and reinstalled ABRP.
Uninstalled and reinstalled LeafSpy Pro.
Deleted the car add it again in ABRP.
Tried it with a different leaf in de drop-down menu.

Hopefully someone can help. If needed I can provide diagnostics.


  • Avatar
Avatar

Matt_ABRP

Status changed to: Investigate

Avatar

David Ebling

Is the value of $token$ correct?


Avatar

David Ebling

I can't scroll down far enough to see the second box with the URL copy button. It stops scrolling as shown in the screenshot. Strangley if I highlight text and extend the selection down I can scroll down to access it. Also if I open the link screen in landscape mode it seems I can half see it, even if I then revert to portrait. Can't get to it by going to landscape from portrait once on the page however!


Avatar

Katya_ABRP

Status changed to: User Feedback

Avatar

Katya_ABRP

Hi David,

The screenshot with "leaf40" might be out of date. There is a 2nd button to copy the link and there we omit the "40".

Please try again with this version.

/Katya


  • Avatar
Avatar

David Ebling

Is the problem that premium is required? It would be helpful if this was explained clearly. The documentation for premium features didn't mention it.


Avatar

Katya_ABRP

Nope! ABRP Premium is not a requirement for any live data source except the Porsche connection at the moment.


  • Avatar
Avatar

David Ebling

Also, the screenshot that you have to read the URL from is really blurry. Does it have "tim" or "tlm" (capital i) or "tIm" (lowercase L) in it? A second copy button would be far better.


Avatar

Katya_ABRP

That's a lowercase L. tlm = telemetry


  • Avatar
Avatar

David Ebling

Should add this is on Android. LeafSpy is working fine.