1

Google Car Location get stuck


M
Michael Brandl

Hi,
I'm using ABRP 4.1.15 (764) on an Samsung Galaxy S9+ with Android 10, in a Hyundai Kona 2019 Model.

I used ABRP for some years now, and now I'm trying the two weeks Pro Test thingy to get Info via ODB and display ABRP directly on the car monitor (via Google carplay).

Everything works, except that the location get's stuck about every 2-5 minutes. The application is not crashed, I can still zoom, and pan around on the map, cancel or start a new route and so on. The location is simply not updated!
If I switch to Google Maps in Google Car play, the location is still updated (I have a video if you want)
So it's not a problem with GPS on the mobile. Also the ABRP app on the mobile is still updating the location correctly.
Only solution is to disconnect the mobile for about 5 minutes from Google Car play, so the process in the background is ended by Android, reconnect the mobile to the car, and location is updated again (for the next 2-5 minutes)

This is a showstopper, completely unusable at the moment. But it is easy reproducible.

Do you need any more info's on this, if so please tell me, and I try to provide them asap.

A

Activity Newest / Oldest

Avatar

Samuel_ABRP

Status changed to: In progress

M

Michael Brandl

You should have two logfiles hopefully.

And I found out, that the problem only occurs, when the Bluetooth ODB dongle is active. I tried twice to also get a location lock without dongle... didn't happen.
The ones where the problem occurred I only needed to reset the APP, not the dongle.


Avatar

Samuel_ABRP

Hi, thanks for the feedback. I did not find the logs, did you have an active internet connection when you sent them (or do you use another account for your premium test)? Also did it show a message like "event log sent with ID xxxx-xxxx-xxxx-xxxx"? If not no event log has been sent.

It's a bit strange that it only happens with OBD dongle connected. Can you please describe a bit more in detail your setup? Do you use OBD connection from ABRP or any third party app?

If possible please send another log (do not only click on the bug icon, but also select one of the bug types in the window that follows, for example "other"). If you are not sure if it was sent you can also just send it multiple times again to make sure it was sent.


M

Michael Brandl

That's what I feared, I thought a succes message would have been nice.
I choose "other", but afterwards there was no progress info about the upload or a success message.

OBD is connected directly in ABRP
If you see my car setups, it's "Kona64 ODB"
And yes, I just saw I made a typo and it should be OBD ;)


M

Michael Brandl

I will try again tomorrow, when I'm driving again


Avatar

Samuel_ABRP

Thanks.


M

Michael Brandl

I tried again. Bug upload only works, if the location is not stuck. You should have now one upload from me, but it wasn't stuck yet, so chances are slim that it helps you...

And now?


Avatar

Samuel_ABRP

No, this does not help, i need to see the log when the map is stuck. Can you stop navigation and does map update then again? Or can you plan a new route? Or does nothing work anymore when the map is stuck?


M

Michael Brandl

I can stop the navigation, but I can't plan a new route.
The location stays stuck.
When you select a new target, it calculates for ever.
So the navigation part of the navigation software is then broken, I still can zoom in and out, and move around on the map. Or press the Bug button and select a bug type, but sending... no
Like I said, the only thing that unstucks the location is to unplug the USB for at least 5 minutes, till android has killed the ABRP task (Maybe doing it with a task manager on the phone would also work, but I don't want to open a task manager when going 130 on a highway ;) )

Is the log stored on the phone? Can I send it to you by hand (Mail, Google Driver or something like that?)


Avatar

Samuel_ABRP

Ok this is a totally different issue then. It's not that the GPS is frozen here, but it seems the underlying navigation service has died. Which also explains why sending bug reports does not work. This is a pretty strange issue i have never heard about yet.

We are currently working on rewriting CP and AA, we already have a pretty good working version, if you want to test it send me a mail to samuel@iternio.com and then i can add you to the testers team. I want to know, if that happens on our improved code as well. Right now i can't explain what could cause your issue, but maybe it is already fixed in the new version (really a lot changed...) so let's try this.


  • M
M

Michael Brandl

Sure, will do in the afternoon


Avatar

Samuel_ABRP

Status changed to: User Feedback

Avatar

Samuel_ABRP

Hi Michael,
I added the tester role to your account. In Android Auto you should see a bug button on the lower right part now when you touch the screen and the other buttons are shown as well.

Please drive until you see that problem again and then when the map does not move anymore click the bug report icon.

Then let me know here when you reported it. I will then check the logs.

Thanks!